BURMA/MYANMAR. WHAT EVERYONE NEEDS TO KNOW


burma-myanmar

David I. Steinberg

Bookshot


Description: In the past two decades, Burma/Myanmar has become a front-page topic in newspapers across the world. This former British colony has one of the most secretive and repressive regimes on the planet, yet it houses a Nobel Peace Prize winner who is and in and out of house arrest. It has an ancient civilization that is mostly unknown to Westerners, yet it was an important–and legendary–theater in World War II.

A picturesque land with mountain jungles and monsoon plains, it is one of the world’s largest producers of heroin. It has a restive Buddhist monk population that has captured the attention of the west when it faced off against the regime. And it recently experienced one of the worst natural disasters in modern times, one effect of which was to lay bare the manifold injustices and cruelties of the regime. Burma/Myanmar: What Everyone Needs to Know offers a concise synthesis of this forbidding yet fascinating country.

David Steinberg, one of the world’s eminent authorities on the region, explains the current situation in detail yet contextualizes it in a wide-ranging survey of Burmese history and culture. Authoritative and balanced, it will be standard work on Burma for the general reading public.

REVIEWS

“Steinberg (Asian studies, Sch. of Foreign Service, Georgetown Univ.) is well qualified to shed light in a balanced fashion on the complex issues that plague the country

… THE BOOK’S

extended question-and-answer format makes this a handy quick reference source for those wanting to cut straight to the main points.

– VERDICT

This is a top choice for students and those with a probing interest in world affairs. Whatever we call it, we are certain to be hearing more about this country.”

–LIBRARY JOURNAL

David I. Steinberg is Distinguished Professor of Asian Studies, School of Foreign Service, Georgetown University.

256 pages

5 1/2 X 8 ¼

ISBN13: 978-0-19-539067-4

ISBN10: 0-19-539067-9

Les commentaires sont fermés.

Your server is running PHP version 4.4.9 but WordPress 4.0 requires at least 5.2.4.